Diablo 3 Save editor
Sign in now to view all the latest guides
Who is online?
In total there is 1 user online :: 0 Registered, 0 Hidden and 1 Guest

None

Most users ever online was 13 on Sat Nov 04, 2017 10:13 pm

Disabling Intel Turbo Boost

Go down

Disabling Intel Turbo Boost

Post by DJM76 on Sun May 27, 2018 1:39 pm

What is Intel Turbo Boost?

Intel Turbo Boost is a relatively new technology, which increases the speed of the Intel CPU on demand, but does it by overclocking it. So basically if your CPU was designed for 2 GHz Clock speed, Turbo Boost can dynamically overclock it to 2.9 GHz based on the workload (these speeds are here just as an example).
Why disable it?

Intel Turbo Boost is very useful in certain situations, especially if you’re doing “heavy” computational work, so you might ask why bother disabling it? Well, I recently found one reason. I sometimes like to play games on my laptop and I often monitor the temperatures. The CPU was idling at ~50 C, while when I was playing a relatively “heavy” game (like Team Fortress2 or Black Ops) it was getting hot, too hot actually. The maximum temperature (according to Intel website) is 100 C for my CPU and I was getting 90-97 C. From my recent overclocking experience I knew that OC = heat, thus I quickly found my first suspect - Intel Turbo Boost. A boost from 2 GHz to 2.9 GHz on a laptop will definitely take it one step closer to frying it, so I knew I must try to disable it. However, after googling for several hours I found out, that there’s no way to disable it (unless there’s a switch in the BIOS, but there was nothing like it on mine). It was a dead end. After few days it struck me - I could play with Windows power settings. And actually it worked! I reduced the CPU temperature to a manageable 80 C (almost 20 C difference!).

And now onto how I did it…
How to disable Intel Turbo Boost?

Well, it’s relatively easy.

   Go into Power options **(Control panel -> Hardware and Sound -> Power Options) and click **Change plan settings near your plan (e.g. I use high performance for CPU intensive tasks, such as gaming).
Copy and paste this shortcut into windows explorer -
Control Panel\Hardware and Sound\Power Options

   Then click on Change advanced power settings.

   Scroll down to Processor power management and expand it.

   Expand Maximum processor state and modify both On battery and Plugged in to 99%.

    Then simply click Apply and OK.

UPDATE:

Also please make sure, that Minimum processor state is not greater than Maximum processor state (in this case - 99%), because this fix won’t work. I suggest you to set it to 5% or so.

And that’s it, no more Turbo Boost, no more overheating and if there is a need - these changes are very easy to revert. What you just did is created a limit, that prevents your laptop to go into such state, when Turbo Boost kicks in.

I hope it helps.

This is the original post I found this on, Disabling intel turbo boost
avatar
DJM76
Overkill
Overkill

Posts : 128
Join date : 2017-07-13

http://djm76.forumotion.com

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum